[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Console Login of kdm disappeared after upgrade to Etch

On Tue, Apr 10, 2007 at 03:44:57PM +0800, Uwe Dippel wrote:
> I did the upgrade, with some minor problems on X.
> In order to debug it, I need a console login. Alas, kdm has lost the 
> 'Console Login' option here. Also, X cannot be killed with a series of 
> Ctrl-Alt-Backspace any longer, it came back here for surely 30 times.
> I tried 'init 3', 'kdm stop' but nothing seems to work (the last one is 
> funny, but there is no message about syntax problems; so what would it 
> do, anyway ?)
> Yes, please, give me back the 'Console' option !

If you can get to an xterm (Konsole?), su to root then type
	#shutdown now

which will take you to single-user mode which _should_ stop kdm and give
you a shell after you enter the root password.

If you can't get an xterm, reboot to single user mode by passing -s to
the kernel (which passes it on to init).

If that still doesn't work, pass the kernel init=/bin/sh which will give
you a shell and bypassing all of init.  The root filesystem will be
mounted ro, you'll need to mount it rw to make the changes you need.


Reply to: