[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

No text mode display after grub


My boss gave me a Dell Latitude D810 to use for work so I didn't have to
use my privately owned Acer Ferrari 4000 anymore. First thing I did was
install testing on it, which was no problem at all. Next I built a kernel (vanilla from kernel.org) and now I have a bit of a
strange problem: after I make a selection in the grub menu I see about 2
lines printed to the console (they flash by too fast to read, but they
do not seem to be error messages). After that the screen stays dark
until kdm starts. Everything else is working like a charm. After logging
in to X I tried to change to a virtual console and noticed text mode
won't work there either. Does anyone have an idea what I could do to get
the text console back? I use it regularly. I tried using the vga=xxx
option [1] as a boot parameter, but either I can't find the correct
value for it, or that is not the solution to this problem.

[1] To be honest I wasn't able to figure out much about how those values
are calculated. The native resolution for this display is 1920x1200,
which is never listed in the tables I found. If anyone could point me to
a good tutorial on this subject I'd appreciate it.


Grx HdV

Reply to: