[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: StartX problem



On Mon, Feb 12, 2007 at 03:56:05PM EST, Kent West wrote:
> conn intel wrote:
> >USING  $ startx $(which xterm) -- :6 , I am getting the blank screen 
> >as said and using ctrl alt backspace i am able to return back to the 
> >command prompt.
> >Here is the output of 'lspci' attached with the email.
> > Note :: I am getting vertical  strips when default system boots or 
> >when i try to start graphical interface...in any case it shows 
> >vertical strips.but it wont go ahead of that and stucks there itself 
> >without prompting for login screen.
> >5)Are you getting any error messages that are not part of the log 
> >files you've included? No.. I am not getting any error message.
> 
> Check /var/log/xorg.0.log (or /var/log/XFree86.0.log) and look for lines 
> with EE or WW. They may be clues. Also, somewhere in that file should be 
> a notice as to which configuration file it's using. Make sure that file 
> is the same one you're tinkering with.
> 
> >6)Have you tried the "vga" driver in XF86Config-4 instead of "vesa", 
> >or have you tried dropping the DefaultDepth from 24 to 16?
> > I have tried all the way.

Both good suggestions in my experience at least. 

Another thing that has worked for me in the past though I am unsure why
is to make sure you boot to the vesafb framebuffer.

You need to give the boot loader and extra parm:  vga=nnn -- something
conservative such as vga=791 should be fine.

In grub it's easy to do it on the fly .. you arrow down to whatever you
want to boot and then type 'e' for edit and then arrow down again to the
line that says something like "kernel" .. type 'e' again .. add the vga
parm at the end of the line .. hit <enter> .. I think .. and then hit
'b' to start booting ..

I'm sure you can do it with lilo as well but I can't remember all the
details.  I think you need to hit <TAB> and after that it's pretty much
the same.

Yeah, I know .. this all sounds a little crazy .. but since it shouldn't
take more than a couple minutes .. I would give it a shot.

Thanks,

cga



Reply to: