[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problem with udev, etch, custom 2.6.20 kernel, and ide devices

I started with a net installed etch rc1 for amd64. I have ASUS M2N-MX mobo
with SATA harddrive and IDE dvd writer. Install went okay, but no sound.
Made a custom 2.6.20 kernel. Now I have sound but no cdrom! The trouble
shows up in udev, but I'm not sure if that's the root of the problem.

hda shows up in /dev/.static/dev, but not in /dev. I can't mount a data cd
in any manner, even if I try
mount /dev/.static/dev -t iso9660 /mnt/cdrom

An audio cd is a little more interesting. I put an audio disk in the drive
and nothing happens. If I run cdplay as root, it works. Additionally, the
links to /dev/cdrom, /dev/cdrw, etc. get created, the autoloader works, and
I can play the disk from KsCD as a normal user (who belongs to the cdrom
group). The cd plays fine for a while (1 to 3 tracks), but then it suddenly
quits. I have no idea what that's about.

I don't know much about udev. There seem to be rules for ide devices
in /etc/udev/rules.d. I tried a few things, like adding 010_local.rules
constaining things like:
SUBSYSTEMS=="ide", KERNEL="hda", NAME="hda", GROUP="cdrom"
BUS=="ide", KERNEL=="hda", SYMLINK+="cdrom", GROUP="cdrom"
but they didn't seem to make any difference.

Any help would be greatly appreciated.

Reply to: