[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: curious USB hard drive problem



On Mon, Jan 15, 2007 at 12:09:08PM -0400, David Garcia wrote:
> To my it happens to me the same. I have a card pci USB 4 ports with chipset
> VIA model VT6212L, and after of several days investigating I could not
> determine if is bug of kernel or is problem with the model of chipset. In
> the end I had to place another card pci with chipset old model VIA VT6202
> and at least I fix the problem to me. I connect a hard disk Maxtor 320GB,
> usb 2.0. If beams rmmode ehci_hcd;modprobe ehci_hcd, fixes of temporary way
> the problem. I believe that is bug with module ehci_hcd because this are
> many happening to him the same. Excuses my ingles.

Interesting - That does suggest that my problem is a Debian/Kernel
compatability issue rather than faulty hardware. Wish I knew what
had changed in the design of this particular enclosure to stop
the newer pcb version from working. Some protocol enhancement that
the Linux kernel doesn't like yet, or cutting a corner to reduce
cost at the expense of compatability?

Another clue I noticed is that if I boot a system from the internal
(non USB) drive, using a non-Debian kernel with all AMDs patches
for this chipset applied, I can plug in the USB drive and it
works fine. But it it is plugged in before the booting then
the drive is recognised but none of the partitions appear
in /proc/partitions.

I think I forgot to mention that this problem was
occuring on an AMD Geode LX system. lspci shows the following
devices on board:
00:01.0 Host bridge: Advanced Micro Devices [AMD] Unknown device 2080 (rev 30)
00:01.1 VGA compatible controller: Advanced Micro Devices [AMD] Geode LX Video
00:01.2 Entertainment encryption device: Advanced Micro Devices [AMD] Geode LX AES Security Block
00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0e.0 Network controller: Intel Corporation PRO/Wireless 2915ABG Network Connection (rev 05)
00:0f.0 ISA bridge: Advanced Micro Devices [AMD] CS5536 [Geode companion] ISA (rev 03)
00:0f.2 IDE interface: Advanced Micro Devices [AMD] CS5536 [Geode companion] IDE (rev 01)
00:0f.3 Multimedia audio controller: Advanced Micro Devices [AMD] CS5536 [Geode companion] Audio (rev 01)
00:0f.4 USB Controller: Advanced Micro Devices [AMD] CS5536 [Geode companion] OHC (rev 02)
00:0f.5 USB Controller: Advanced Micro Devices [AMD] CS5536 [Geode companion] EHC (rev 02)

One last experiment I tried - I didn't have any other machine with a
bios that could boot from USB HDD, but tried booting to this drive
from my notebook by putting grub on a CD. Booted fine on the old
enclosure, but with the new enclosure get:
	root (hd1,4)

	Error 21: Selected disk does not exist

So it doesn't seem to be a problem limited to AMD chipsets.

Regards,
DigbyT
-- 
Digby R. S. Tarvin                                          digbyt(at)digbyt.com
http://www.digbyt.com



Reply to: