[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xsane usb problem -buffer not cleared?

On Sat, Jan 13, 2007 at 01:26:47PM -0800, Andrew Sackville-West wrote:
> On Sat, Jan 13, 2007 at 10:23:00AM -0500, Thomas H. George wrote:
> >  A binary scan works, a color scan stalls the scanner.
> > 
> > A posting to sane-devel on 1/6/07 drew no responses.
> > 
> > The backend maintainer pointed out that "If the USB system stalls, the 
> > scanner can not get rid of it's data".  I tried scanimage -B to increase 
> > the buffer size but this did not help.  Actually, after reinstalling 
> > xsane and libsane I was able to complete one color scan but the second 
> > one stalled.
> try this. get your one good scan, then pull the usb cable (while
> watching syslog) and then put it back in. Make sure udev removes and
> inserts modules correctly and try again. 

Wild result.  Pulling scanner cable - no problem.
	      Pulling wacom tablet cable - partial lockup.
	        tablet not restored, xsane can't find scanner,
		xane cannot be killed, lsusb locks one terminal,
		can open another terminal but lsusb cannot be killed,

Since I had to reboot I first downloaded linux-source-2.6.18, built the
new kernel and rebooted to it.  After this I was able to complete four
color scans before the scanner stalled on a fifth scan.  I tried
deleting everything in /tmp which is the directory I set in xsane.  This
did not resolve the problem.

My assumption:  Somewhere there is a buffer that usb uses and it is not
being cleared.  Even rebooting the system does not resolve the problem
though earlier reinstalling xsane temporarily solved the problem - i.e.
one color scan worked before the scanner stalled.

> Also, one thing that can cause usb
> to stall would be too much stuff coming down the pipe. what else do
> you have plugged into that usb channel? lsusb would help here. Maybe
> you need to split some of your usb stuff onto different controllers. 

The lsusb output:

Bus 004 Device 010: ID 04b8:011b Seiko Epson Corp. Perfection 2400 Photo
Bus 004 Device 001: ID 0000:0000  
Bus 001 Device 003: ID 056a:0015 Wacom Co., Ltd 
Bus 001 Device 001: ID 0000:0000  
Bus 003 Device 003: ID 051d:0002 American Power Conversion Back-UPS Pro 500/1000/1500
Bus 003 Device 002: ID 03f0:8204 Hewlett-Packard (the printer)
Bus 003 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  

Baring a power failure there should be nothing extra going on during a
> > 
> > The system is Debian testing with a 2.6.16 kernel.  The scanner is an 
> > Epson Perfection 2400 which is recognized as a usb2 device.  It has 
> > worked flawlessly with xsane for the past several years.  Recently I did 
> > several apt-get updates and apt-get dist-upgrades.  It is after these 
> > upgrades that I have encountered the problem.
> do you know what version? check the changelogs? might need to file a
> bug about regression. 
> > 
> > I have confirmed that the hard drive is using dma and 32 bit i/o.  There 
> > is 775 Mb memory and all the partitions have at least 2 Gb of free space.
> looks good to me. 
> .02
> A

Reply to: