[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xsane usb problem

On Sat, Jan 13, 2007 at 10:23:00AM -0500, Thomas H. George wrote:
>  A binary scan works, a color scan stalls the scanner.
> A posting to sane-devel on 1/6/07 drew no responses.
> The backend maintainer pointed out that "If the USB system stalls, the 
> scanner can not get rid of it's data".  I tried scanimage -B to increase 
> the buffer size but this did not help.  Actually, after reinstalling 
> xsane and libsane I was able to complete one color scan but the second 
> one stalled.

try this. get your one good scan, then pull the usb cable (while
watching syslog) and then put it back in. Make sure udev removes and
inserts modules correctly and try again. Also, one thing that can cause usb
to stall would be too much stuff coming down the pipe. what else do
you have plugged into that usb channel? lsusb would help here. Maybe
you need to split some of your usb stuff onto different controllers. 

> The system is Debian testing with a 2.6.16 kernel.  The scanner is an 
> Epson Perfection 2400 which is recognized as a usb2 device.  It has 
> worked flawlessly with xsane for the past several years.  Recently I did 
> several apt-get updates and apt-get dist-upgrades.  It is after these 
> upgrades that I have encountered the problem.

do you know what version? check the changelogs? might need to file a
bug about regression. 

> I have confirmed that the hard drive is using dma and 32 bit i/o.  There 
> is 775 Mb memory and all the partitions have at least 2 Gb of free space.

looks good to me. 



Attachment: signature.asc
Description: Digital signature

Reply to: