[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [SOLVED] /dev/fd0 problem

On Tue, Jan 02, 2007 at 09:47:28AM -0600 or thereabouts, Hugo Vanwoerkom wrote:
> Stephen wrote:
> >Happy New Year !
> >
> >I did something stupid, when tired and working as root. 
> What did you do?

Hi Hugo:

I believe I did 'rm /dev/fd0/*' 

Anyhow, I've fixed this. I did some reading, (imagine that) and found that
via issuing some commands I could find out exactly what was happening in
a more verbose and useful way. Oh joy.

After finding out about the 'fdmount' command, and, once run I was given
the following message;

	fdmount (): ioctl(FDGETDRVTYP) failed on /dev/fd0: Inappropriate
	ioctl for device
	fdmount (): drive fd0 does not exist

It was via that last line, that I was able to determine, that what I had
issued a few hours earlier, was  most likely 'rm /dev/fd0/*' because,
finally I was given a more verbose message other than just
"Inappropriate ioctl for device".

So, I did some more reading and discovered that '/MAKEDEV fd0' should
replace the missing fd0 drive. It worked ! Yay !

I should have been more careful when working as root and using the 'rm'
command, obviously. Lesson learnt.

In the plot, people came to the land; the land loved them; they worked and
struggled and had lots of children.  There was a Frenchman who talked funny
and a greenhorn from England who was a fancy-pants but when it came to the
crunch he was all courage.  Those novels would make you retch.
		-- Canadian novelist Robertson Davies, on the generic Canadian

Attachment: signature.asc
Description: Digital signature

Reply to: