[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.6.14-2-386, missing thermal.ko and initrd

Eddy Parris wrote:
Hi everyone and happy new year :)

Sometime over the weekend I had a power blip that shut ny debian sarge box down.
When i booted it this morning i found this lovely message:

Begin: Running /scripts/init-premount ...
FATAL: Error inserting fan (/lib/modules/2.6.14-2-386/kernel/drivers/acpi/fan.ko): No such device
FATAL: Error inserting thermal (/lib/modules/2.6.14-2-386/kernel/drivers/acpi/thermal.ko): No such device

it then leaves me with a simple busy box shell with only what is in the initrd.
Now, this machine was up for probly 3-4 months or so before it went down, I have not updated in a while
as i dont ever login and use it that often but it has a few cron scripts and nfs shares that are pretty important
and i really need to get them back.
I think the problem is that when i did last update it, it updated the kernel and told me to reboot asap...
...which i probly just forgot about so when it has come back up it has not had an updated ram disk with
these new drivers and cant boot. silly of me i know but its happened and i really need to get this
back up asap.

Does anyone have a clue of how i can a) boot off a cd and then maybe chroot and create a new ramdisk
(not sure this is the best way but the only thing ive thought would work so far)
or b) any other ideas are welcome!

If anyone has a clue how to save this i would be very very grateful

thanks alot

Edd Parris

and backups don't exist?


Reply to: