[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

weird mousing on several Debian systems

Weird mousing on two Debian systems

(1) Last night, when I started firefox on my AMD-64 etch machine, it 
complained firefox was already running.  Fair enough -- I have one 
shared home directory used on several machines, and it probably *was* 
already running somewhere else.  Firefox seems to do its locking on an 
all-or-nothing basis, and so it refused to run.  I didmissed the message 
window and went to do something else.

But after that, the mouse didn't work properly.  It would move around 
OK, but I couldn't click on anything.

But ctrl-alt-backspace still killed X, and brought me back to gdm, 
which let me log in and after that everything worked properly. I tried 
starting firefox again, gor the same no-go message, but when I dismissed 
it this time everything was OK.

The most recent upgrade to this machine was a week ago (as mentioned in 
one of the messages in the Debian bug report log 
and it has performed properly from then to last night, when this 
behaviour suddenly happened.

Since ctrl-alt-backspace appeared to solve the problem, I decided not to 
investigate -- after all, what was left to investigate?

(2)  But then this morning I logged in through gdm on another machine, a 
32-bit sarge system.  Again the mouse misbehaved, but differently.  This 
time, it would register mouse clicks only when I clicked slightly below 
the icon or menu item.  This was impossible on the icons on the bottom 
bar, btu I could gain access to applications using the background's 
menu. By the way, gdm is the screen manager on both this machine and the 
AMD-64 I mentioned above, and this is one of the other machines where I 
use the same home directory, NFS-mounted.

Once I started firefox, mouse behaviour changed.  It seemed to sense 
window boundaries correctly, but I had to click near icons instead of on 
them, and not always in the same direction.

I exited icewm through a regular logout, got back to gdm and started up 
again, remembering last night's experiences.  Back in icewm. I not had a 
one-centimetre offset to the right; i.e., to click on an icon or menu 
item or scroll-bar one centinetre to the right of where it was.  A few 
icons could not be clicked at all (like the forward and back icons in 
firefox).  This behaviour was the same for the toolbar at the bottom of 
the screen.  I logged out bu clicking 1 cm to the right of the logout 
menu item, and was back in gdm.

This time I decided to check out gdm.s icons.  Its language, session, 
and actions items lit up when the mouse was one cm to the right of them.

Now I have six virtual X consoles.  This behaviour occurs on only one of 
them, the one I reach with ctrl-alt-F11.

I logged in on another virtual console just now to send this message, 
and everything is behaving itself.

Any ideas?

-- hendrik

Reply to: