[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: if I were a newbie how would I get sound?

Douglas Tutty wrote:
Yesterday I downloaded xorg.  Today I downloaded some apps (I'm on very
slow dialup at 1.5-2.5 KB/s) and alsa.  Tomorrow I'll get something that
will make a sound.  I ran alsaconf which is supposed to get things set
up and raise default (0) mixer levels.  I then played speaker-test and
got nothing out of the headphone jack on the front of the computer.  I
don't have speakers.  Once I get everything I need downloaded then I'll
poke around a bit.  Right now I'd just like to listen to a CD.  Later,
I'd like to listen to radio shows I missed on cbc.ca.


I originally had a problem getting my PCI sound card to work. Eventually, I found out that the system had auto-detected sound integrated into the motherboard. The solution is to choose the correct card from within Alsaconf. Here is a record of what worked for me (in Etch):

1. Check for cards
   $ lspci | grep audio
00:0e.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10) 00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)

2. Choose and configure a card
   # alsaconf
   Terminating processes: 2497.
Unloading ALSA sound driver modules: snd-seq-dummy snd-seq-oss snd-seq-midi snd-seq-midi-event snd-seq snd-cmipci snd-via82xx-modem snd-via82xx snd-ac97-codec snd-ac97-bus snd-opl3-lib snd-pcm-oss snd-mixer-oss snd-hwdep snd-pcm snd-mpu401-uart snd-rawmidi snd-seq-device snd-timer snd-page-alloc.
   Building card database...

   (Sound card selection dialogue)

   Running update-modules...
   Loading driver...
   Setting default volumes...

   Now ALSA is ready to use.

3. Play a sound file in eg Totem and adjust levels with eg Alsamixergui

4. Things to try if still not working

a. Check file permissions - is your user in the group audio?

b. If you do

   # cat /dev/urandom > /dev/audio

..as the root user do you get static noise? (Kill with Ctrl-C.)



Reply to: