[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: (SOLVED: I think) opening URLs in Firefox from Thunderbird using upstream programs

Marc Shapiro wrote:
Marc Shapiro wrote:

Adam Hardy wrote:

Marc Shapiro on 04/12/06 01:38, wrote:

I am running Etch and want to continue to use the branded Firefox (2.0) and Thunderbird. I do not want to switch to Icedove and IceWeasel. I have been running the upstream Firefox 2.0 for a while, now, with no problems. When I switched from debian-thunderbird to the upstream version ( urls stopped opening in firefox. They have, in fact, stopped opening in anything.

I have made sure that /etc/alternatives/x-www-browser is pointing to the proper firefox binary and I don't know what else to check. I can not find any configuration option, or preference, that says where links should open, only where html attachments should open. Can anyone tell me what I am missing?

Are you sure you mean urls stopped working in FF? Not TB? If TB, then try going into your preferences / Advanced / General / Config editor, and edit the following property:


to point to the firefox app.

I must not have been clear. I fully expect that the problem is with Thunderbird and not Firefox. I looked for that configuration item and did not see it. I will have to check again tonight, when I get the time to check into it. I was about to add the line manually to prefs.js. I also found a reference to setting network.protocol-handler.external.http to false and setting network.protocol-handler.expose to true, as well. I will have to look for these, this evening, as well. I will report back if I have any success.

I could not find that configuration item in the list. I exited thunderbird and manually added the lines to prefs.js and then restarted thunderbird. The preferences then showed up, but it did not change anything. Thunderbird still fails to send the url to firefox. Since the debian package of thunderbird had worked previously, I decided to try icedove. It did not work, either. If I can't get links in my e-mail to open a browser, I may have to just stick with Sarge and not upgrade at all.

Any other suggestions?

BTW, I read something about firefox requiring gconf to handle this. Is that true? Because I do not have gconf installed on the Etch partitions.

Now I feel silly! As neer as I can tell, all that I needed to do was to set the network.protocol-handler.app.http config option using the FULL PATH to the firefox binary. I did not need gconf, just a complete path.

Thank you to all who responded.

Marc Shapiro

Reply to: