[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Yes, I really did it!

rm -rf /

I really did it. I was pretty angry at the time, about ready to take a very large hammer in hand and reduce that old, obsolete i386 box to scrap.

I've had some time to cool off, only took 3 years, so now I want to bring it back from the dead.

The first time I put Debian on it, it took about ten 1.44mb floppies, and about 3 days. Then the 2.4 kernel come out, with iptables. I resisted as long as I could stand it, but eventually I had to upgrade. That took about 20 floppies and about ten days, but it worked.

Then 2.6 came out, and the upgrade was a disaster. I went looking for that hammer.

It was a foot stool, for quite some time, but eventually tired of stumbling over it in the dark, it went into the basement. Since then my LAN has expanded, and I would prefer more control over my firewall. More control than I have with Windows XP, and McAfee.

So I'm thinking, if I could just stuff enough code into that old box to do a bootp thingy, and download a kernel from the bootp server. . . . .

After many twists and turns in a maze of twisty little passages, all alike, I have arrived at the point where the kernel boots, mounts via NFS a root partition on an NFS server, and attempts to open /dev/console, where it fails, then announces :

failed to init, perhaps passing init parameter to kernel

kernel panic. . . .

What? it can't execute /sbin/init from the NFSroot? It can't execute code from the NFSroot? Well, it can't create /dev nodes either, 'cuz root is mounted read only, but the same thing happens when booting from a local hard drive.

What would happen when the booting kernel tried to do a fsck on the NFS root?

There isn't a root partition on the local HD. (Well, its there, but remember the rm -rf / ?)

There isn't a /dev node when a system first boots up, how does it get created?

Many suggestions around suggest an initrd parameter should be passed to the kernel at compile time, but then a huge initrd.img.gz gets created, and it won't fit on the boot floppy.

Doing a bootp and tftpboot 'should' work by stuffing a kernel image, and the initrd.img into the box over the LAN.

and that is where I am stuck. Anyone care to hit me with a clue?

How do I tftp the kernel image, and initrd.img over the LAN to that old i386? Or, what can I do to create /dev/console, and some kind of inittab that the kernel will execute so I can get a command prompt? These are old NIC's, and don't have bootp code. I can even stuff pxelinux.0 in the box, using syslinux, as though it were a kernel, but it fails to find an API to work with, and gives up.

Coyote Linux has a one floppy NatBox, (http://www.coyotelinux.com/downloads/channel.php?ChannelID=5) but it is not compiled for a buggy i386. I am currently stumbling through the build process using the coyote linux source tree, but haven't yet achieved success there. (Could happen at any moment.) But that won't give me access to the local hard drives in that box to repopulate the file system.

The Debian installer (on four floppies) won't work either. Only 8mb RAM in that box, and after the boot floppy, the installer can't read the second floppy!! (It is readable on other desktops.)

CDrom is probably out of the question. I don't think you can buy a CDrom ISA card anymore. I actually have the ZIP drive SCSI card in there, but Debian has never recognized it, nor can that system boot from it.

I tried the one floppy NetBSD version (http://www.fml.org/software/fdgw/). . . .
it didn't work, but at the moment I can't remember why. .

Guess I should sleep now, eh?

thanks for reading.

Use your PC to make calls at very low rates https://voiceoam.pcs.v2s.live.com/partnerredirect.aspx

Reply to: