[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: modprobe error

Kostas Robotis wrote:

> Hello, I am new to linux ;) I have Debian Sarge with kernel
> and I want to load
> x_tables module in order to have the ip_tables. The "mod_probe
> x_tables" writes the following to the eventlog:
> Oct 28 20:55:41 localhost kernel: x_tables: version magic '
> preempt mod_unload PENTIUM4 REGPARM gcc-3.3' should be ' 386
> REGPARM gcc-3.3'
> Anyone can help?
Hi Kostas,
It's possible that the gcc version that the kernel was compiled with does
not match the version you compiled the module with. This is just a guess
but that does cause problems for loading modules.

Reply to: