[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Etch apt-get "dependency trap"

On Sat, 28 Oct 2006, jdkaye10@yahoo.es wrote:

> I'm in serious trouble here. I was upgrading from xorg 6.9 to 7 but my
> problem is the usual one. Everything was fine until wajig reported that
> the /usr/X11R6/bin directory wasn't empty. It suggested moving the files
> somewhere else and then restarting the install. I did this and then all
> hell broke loose. Redoing wajig install xserver-xorg aborted again with
> dependency problems and suggested I run apt-get -f install, which I did.
> That only made things worse. I am now completely stuck. installing,
> reinstalling, holding, removing or any other operation using, apt-get,
> aptitude, wajig all abort. Running apt-get check gives this:
[ . . . ]
> dpkg: error
> processing /var/cache/apt/archives/xbase-clients_1%3a7.1.ds-3_i386.deb
> (--unpack):
>  trying to overwrite `/usr/bin/xgamma', which is also in package unicon
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
> Errors were encountered while processing:
>  /var/cache/apt/archives/xbase-clients_1%3a7.1.ds-3_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> ----------------------------------------------------------------------
> Any ideas would be extremely helpful

Try 'apt-get remove unicon' followed by the 'apt-get -f install'.  You can
always reinstall unicon after apt gets the xorg upgrade sorted out.

If apt is really wedged then 'dpkg -r unicon' might work to clear the

I had a similar issue while upgrading a machine to etch earlier this week
and I'm pretty sure one or the other invocation solved it for me. (I now
wish I paid more attention) so I could tell you for sure.)

-- Brad

Reply to: