[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't boot after installation ==> ALERT! /dev/sda1 doest not exist. Dropping to a shell.

debian wrote:


Thanks for the information,
I tried some things and I hope I am little bit closer to the solution.

This is what I have done:
Rebooted with a rescue cd and changed the label of /dev/sda1 to /root
"Jfs_tune -L /dev/sda1 /root"

When I check my settings with jfstune:
Jfs_tune -l /dev/sda1
Volume Label:	'/root'

With cfdisk:
with cfdisk
SDA1		BOOT		Primary	Linux JFS
SDA2				Primary	Linux Swap / Solaris

So I guess this is correct.
(I also changed label of swap partition but appearantly that's not
shown, weird)

Then I mounted my disk and changed /etc/fstab:

#/dev/sda1		/	jfs	defaults,errors=remount-ro
0	1
LABEL=/root		/	jfs	defaults,errors=remount-ro
0	1
#/dev/sda2		none	swap	sw
0	0
LABEL=swap		none	swap	sw
0	0

I changed /dev/sda1 with LABEL=/root

Then I changed menu.lst from grub:
title		blahblahblah
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.16-2-686 root=LABEL=/root ro
initrd		/boot/initrd.img-2.6.16-2-686

I saved everything and rebooted the system.
Then when I boot, I get this:

ALERT! /dev/disk/by-label//root does not exist. Dropping to a shell!

BusyBox v1.1.3 (Debian 1:1.1.3-2) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

/bin/sh: can't access tty; job control turned off

So, appearantly the system can't find /root label or can't link it with
/dev/sda1 ?
Maybe because /root is not in the /dev directory (according the error).

I tried to make a link (ln -S /dev/sda1 .//root

But error stays the same.

So maybe the /root is wrong ?
I change the label to test
Jfs_tune -L /dev/sda1 test
Cfdisk shows me 'test' for label
I changed fstab and menu.lst and made a link in /dev/
From test to sda1 (don't know if this is necessary but just trying...)

Result is the same error, not working.

What do I do wrong in this label/boot thing ?

Grtz, (and thnx for helping me out!)

-----Original Message-----
From: Bob McGowan [mailto:bob_mcgowan@symantec.com]
Sent: donderdag 26 oktober 2006 17:53
To: debian
Subject: RE: Can't boot after installation ==> ALERT! /dev/sda1 doest
not exist. Dropping to a shell.


My intent in sending you to the archives was to save bandwidth in the
newsgroup.  I did not know about the 'missing' messages, a problem which

seems to reflect a time lag in getting the data linked in.

So, again in the interest of reducing bandwidth, and repetitive posts,
I'm sending the details to you directly.

I hope the attached information is helpful.


Disclaimer :

This e-mail is intended for the exclusive use by the person(s) mentioned as recipient(s).
If you are not the intended recipient, please notify us immediately.
This e-mail does not constitute any commitment for Sea-Ro Terminal N.V. or its subsidiaries except when expressly otherwise
agreed in a written agreement between the intended recipient and the originating subsidiaries of Sea-Ro Terminal  N.V.
Sea-Ro Terminal and each of its subsidiaries each reserve the right to monitor all e-mail communications through its networks.

This mail has been checked for viruses by Symantec and Trend Micro.

OK, this should have worked. So I need some context, which is no longer part of the message. Which Debian system are you running (stable, testing, unstable)? I'm using testing, with udev support. It may be that my fixes are specific to the release I'm using.

I'm not knowledgeable in the workings of udev, so other than saying you may need it for this to work, I cannot provide any further assistance with your issue ;( and will have to defer to others on the list.


Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Reply to: