[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem: modprobe wacom failure

modprobe wacom results in:

wacom: version magic '2.6.16Jun03 preempt K7 gcc-4.1' should be '2.6.16Jun03 preempt K7 gcc-3.3' FATAL: Error inserting wacom (lib/modules/2.6.16Jun03/kernel/drivers/usb/input/wacom.ko): Invalid module format.

Background: The box was Sarge with a 2.6.11 kernel and the wacom graphire tablet was working perfectly. I decided to upgrade to testing. First I used apt-get source linux-source-2.6.16, copied .config from the 2.6.11 source file to the 2.6.16 source file and compiled the new kernel. The system rebooted with no problem using the new kernel. Next I modified sources.list changing Sarge to testing, ran apt-get update and then apt-get dist-upgrade. The setup failed when trying to setup wacom with a message that a wacom 2.6.11 header did not match the current system. I purged wacom and ran apt-get install wacom-kernel-source. This put wacom-kernel-modules-2.6.16Jun03_0.7.4.1-5_i386.deb in /usr/src/modules. At this point I ran apt-get dist-upgrade again. The reuslt was 0 upgraded, 0 newly installed, 0 to delete and 41 not upgraded. Finally, I ran dpkg -i wacom-kernel-modules-2.6.16Jun03_0.7.4.1-5_i386.deb. At this stage the modprobe wacom fails as reported above.

I don't understand why the above sequence would produce the wrong module. dpkg -l gcc* produces a listing showing ii for both gcc-3.3 and gcc-4.1. Must I somehow force dpkg to build the module using gcc-3.3? If so, how?

I would appreciate any help with this problem as I only have a wacom mouse so I can only use the consoles. (My old mouse died of fur balls.)


Reply to: