[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Downgrading OpenOffice

David Baron wrote, On 2006-10-04 01:43:
Since rc2-1 is broken beyond any operation, I put in rc1-1 which had worked.

1. Got the spreadsheets back.
2. Can read and edit a document only if I run soffice.bin explicitely.
3. Can export and reimport RTF but cannot any other RTF from before.
4. Can read doc files using soffice.bin explicitely. If I have not had any crashes yet running openoffice, doc files will open with this.

How do I procede to get the downgrade working the way it was before .... ??

BTW. Yes, I know, it's "unstable" but a simple read file, do something, save, reread and such should be the minimum regression test for any "office" product, don't you think?

To get a working OOo, I went back to the version in testing. I renamed my ~/.openoffice.org2 directory (some recovery stuff was fouling things up) and then purged all the openoffice* packages before reinstalling OOo 2.0.3-6. (You may need to copy existing config files to other locations to keep them for reference if you have customised OOo significantly).

I think that some of the answer to why the problem happened might be to do with the automated OOo test suite not catching the issue, and part of it also seems to be the way that not much debugging information is left in the distribution packages. If I have the disk space to spare, I'd appreciate having debugging information left packages in Sid for these kind of situations.


Reply to: