[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: modern Gnucash still needs libglib1.2?

Andrew Sackville-West wrote:

> On Tue, Oct 03, 2006 at 08:34:02AM -0400, Roberto C. Sanchez wrote:
>> On Tue, Oct 03, 2006 at 06:12:42AM +0200, Tshepang Lekhonkhobe wrote:
>> > Hi,
>> > I just noticed that 'gnucash' depends on 'guile-g-wrap', which in turn
>> > depends on 'libglib1.2'. Is there anything available there not yet in
>> > 'libglib2.0' or has 'guile-g-wrap' not ported yet?
>> > 
>> IIRC, there is currently an effort under way to eliminate all the gtk1.2
>> and related dependencies from gnucash.  It appears that the transition
>> is not yet complete.
> AFAIK, from lurking in gnucash-devel and -user, that conversion was
> completed with the release of gnucash 2.0. That is gnucash has
> completed its gtk2 port. They (gnucash) however, do not maintain
> guile-g-wrap and can't be responsible for the dependencies of their
> dependencies... heh.

Doesn't it cause segfaults if gnucash is linked (directly or indirectly)
against two different ABI versions of libglib?  Or does glib use symbol
versioning to prevent that?

Kevin B. McCarty <kmccarty@princeton.edu>   Physics Department
WWW: http://www.princeton.edu/~kmccarty/    Princeton University
GPG: public key ID 4F83C751                 Princeton, NJ 08544

Reply to: