[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X programs inside chroot

James Richardson wrote:
> Greetings!
> I have setup an i386 chroot (sarge) on my amd64 (also sarge) on my
> laptop. However I cannot run X programs inside. I get the error can't
> open display: :0.0.
> I get the error from xterm and OpenOffice.
> I have mount /proc inside the chroot.
> At first I thought it may have been a permission problem, so I ran
> xhost + on the X server to disable access control.
> Can anyone help me out here?
I solved my own problem, Here is the solution:
I bind mounted /tmp in the chroot (e.g. mount --bind /tmp

Why did this solve the problem?

* The X server on the host did not have a TCP/IP listener, only a unix
* domain listener (e.g. /tmp/.X11-unix) which was not available in the
* chroot until I bind mounted /tmp.

* Another solution would be to have the X server listen on an IP
* address,which I disremember how to do off of the top of my head.

> Oh, I build the chroot using:
> cdebootstrap -f minimal --arch i386 sarge /chroots/sarge-ia32
> http://apt.lan0:9999/debian
> I then mounted /proc inside the chroot, copied /etc/resolv.conf,
> /etc/passwd, /etc/group, /etc/shadow, /etc/apt/sources.list.
> I then chrooted (chroot /chroots/sarge-ia32), installed openoffice and
> xterm.
> James richardson

Attachment: signature.asc
Description: Digital signature

Reply to: