[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can't resize partition with qtparted / parted


I would like to install Debian in a second partition beside fedora but can't resize my fedora partition neither with qtparted nor with parted. parted prints the following warning message:

Warning: You requested to resize the partition to 12103.660 - 41076.643MB.
  The closest parted can manage is 12103.660 - 71076.643MB.

12103.660 - 71076.643MB is exactly the current size I want to change...

QTparted, started from SystemRescueCd ( http://www.sysresccd.org ), would print to have been successful - but not resize anything...

Also, parted seems not to be able to understand the file system of my fedora installation.

Number  Start   End     Size    Type      File system  Flags
1       32kB    13GB    13GB    primary   ntfs         boot
3 13GB 13GB 107MB primary ext3 4 13GB 75GB 62GB extended lba
5       13GB    75GB    62GB    logical                lvm
2 75GB 80GB 5489MB primary fat32 (This listing was generated with parted installed in fedora; when I actually tried to resize the partition I used the version on the newest Knoppix CD. As Knoppix couldn't find an xserver working with my graphics card I couldn't use QTparted and therefore tried to resize with parted.)

By the way, I also used QTparted (but an older version from SystemRescueCd) to get the space from the Windows partition when I installed fedora...

What can I do? Should I use some other tool - and if so, which one could work?

Thanks, Dietrich

Reply to: