[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Compiling flops.c

David A. Parker wrote:

I am trying to compile flops.c on my Debian (etch) system.  I have used
gcc 3.4, 4.0, and 4.1 with the same result.  This is the output I receive:

$ gcc-4.1 -o flops flops.c
flops.c: In function 'main':
flops.c:174: warning: return type of 'main' is not 'int'
/tmp/cce46kOB.o: In function `main':
flops.c:(.text+0xc4): undefined reference to `dtime'
flops.c:(.text+0xd0): undefined reference to `dtime'
flops.c:(.text+0x113): undefined reference to `dtime'
flops.c:(.text+0x18e): undefined reference to `dtime'
flops.c:(.text+0x1e2): undefined reference to `dtime'
/tmp/cce46kOB.o:flops.c:(.text+0x203): more undefined references to
`dtime' follow
collect2: ld returned 1 exit status

I also tried compiling it on a Solaris system with gcc 3.4 and had no
luck.  Any ideas about how I can get flops to compile?

After 10 seconds of Googling, I found the source code.

Have *you* looked at the source code and followed the instructions
in "Timer options."?

My apologies for not catching that. I did open the source code in vi, but I immediately searched it for 'dtime' instead of reading through it first. Thank you for your reply.

    - Dave


Dave Parker
Utica College Department of
Integrated Information Technology Services
Data Processing Office
(315) 792-3229
Registered Linux User #408177

Reply to: