[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Building my own Perl on Sarge AMD64

Neil Gunton wrote:
Roberto C. Sanchez wrote:

Obviously there are issues with building your own perl, but I'm sure it must be possible to do it using the "official Debian way". Can anyone give me a step-by-step instructions on how you're supposed to build your own Perl on a Debian system, while still keeping everything happy?

If you want to customize your Perl packages, then check out my HOWTO on
building custom Debian packages:


Of course, be careful.  :-)

Thanks for this. I tried going through the process, simplifying in parts (e.g. when I do stuff like this I just run as root). First I got the three perl source files from packages.debian.org. I couldn't use apt-get sources because my /etc/apt/sources.list apparently doesn't have any source lines for AMD64 and I have no idea what I am supposed to put in there. So I just downloaded the files direct from the website.

I then had to install a couple of the toolkits we apparently need for building debian packages - devscripts, sudo, pbuilder. That went without any issues.

I looked around in the source code for Perl to see where I could tell it not to build multithreaded. The only place I could find was in debian/config.debian, so I removed the --Dusethreads line from there.

Then I was at the point where I run pdebuild in the perl-5.8.4. It failed at first, telling me that I needed to run <pbuilder create>. So I ran that, and it chugged for a while, apparently fetching packages to create a build environment. It failed on this:

E: Couldn't download slang1a-utf8
pbuilder: debootstrap failed

So I don't know why that happened... anybody with an idea?



I don't know if this is relevant, but I just noticed this when running pbuilder create:

root:/usr/src/perl-5.8.4# pbuilder create
W: /root/.pbuilderrc does not exist
Distribution is sid.
Building the build environment
 -> running debootstrap
I: Retrieving debootstrap.invalid_dists_sid_Release
I: Validating debootstrap.invalid_dists_sid_Release
I: Retrieving debootstrap.invalid_dists_sid_main_binary-amd64_Packages
I: Validating perl-modules
I: Retrieving sed
I: Validating sed
E: Couldn't download slang1a-utf8
pbuilder: debootstrap failed
 -> Aborting with an error
 -> cleaning the build env
-> removing directory /var/cache/pbuilder/build//11973 and its subdirectories

Why does it mention 'sid' as the distribution? I am running Sarge. Where does it get Sid from? Is this something I should be concerned about (apart from the actual error that occurs later)?

Thanks again,


Reply to: