[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

HP dc7600 Sound installation issues.


Recently we've acquired some HP dc7600 workstations where I go to school and one of them was assigned as a small Linux server/station at the office.

I installed Debian Etch (from the latest snapshot) and everything is great, network, HD, DVD, video. But the sound has been a pain to install. I googled for course and found out that there is a small bug with the sound in this workstation and the kernel ALSA[1]. I aptitude installed the 2.6.16 kernel source from repository, edited the patch_realtek.c file according to the patch and recompiled and installed (using make-kpkg & dkpg -i).
I rebooted and no sound came from the system. I installed a mixer (alsamixer) and tuned up the volumen and all, tried playing an mp3 using xmms and at first it said to check the sound card and yada yada, I checked the options and XMMS was using the OSS module, so I selected the ALSA module and I clicked play, xmms plays but no sound comes from the system.

lspci shows:

0000:00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
Subsystem: Hewlett-Packard Company: Unknown device 3010
Flags: bus master, fast devsel, latency 0, IRQ 21
Memory at e0a00000 (64-bit, non-prefetchable) [size=16K]

And I did everything according to a small howto from Matt Musings[2]. But nothing worked, I even installed from sources with the small patch, and didn't work either.

Am I missing anything?, can anyone if possible share some light on how to install it?.

Thank you again,



Reply to: