[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Xorg Freezes, only root..

Hi All:

 Christopher, many thanks for all your recomendations: problem solved,

Basically i had a lot of self compiled packages such KDE and many
others, the problem was the major libc6  family upgrade, conflicts
with my old packages and new libs, etc, ... Erasing the ancient
packages and runing the dpkg --reconfigure, upgrading with DEB's kde
and Qt--- etc. was the solution, donwloading the nvidia newest driver
and comiling it,

 nvidia driver was not the problem, neither the xorg conf, just
checking the conflicts
between libs and packages installed vs. new one's.

Indeed my xwindows systems is perfect, now i have some interesting
problems related to the same issue, for example, i can't use xmms,
because causes SIGSEGV, my mplayer compilation fails: SIGSEGV. Maybe
some libs are missing or out-of-date

Well... as moral:
  If you made a major dist-upgrade, ONLY use the .DEB from the site,
apt will give all the stuff... :)

-I will need to recompile a lot of software... better than patch and
symlinks the courrent

Regards, and again thanks

Sir. Cc

2006/6/9, Christopher Nelson <chris@cavein.org>:
On Fri, Jun 09, 2006 at 12:29:52AM -0500, Cederik León De León Acuña wrote:
> Hi all:
> After an dist-upgrade, only root can use the xwindows system, in XFREE
> 4 i had no problem, but since yesterday the XFREE -> Xorg "upgrade"
> turns my Laptop, almost unusable under X ...
> I figured out that the problem coms from NVidia driver or so, but i
> tryed with and without nvidia driver, last night without good news..

How did you determine it's the Nvidia driver?  IE, what error makes you
think this?

> Ok...
> After a lot of little xorg.conf changes tests and kernel reconf. the
> problem it's the same, with or withoht nvidia kernel module nor
> driver.
> If a common user [me] try :
>   $ startx

Since you've said 'common user' I assume you've tried with a freshly
set-up user?  IE, one with no .xsession or .xinitrc

> All it´s fantastic, until the end of the "Xwindows startup process",
> then BLANK SCREEN and the entire computer is dead, freezes, no key
> works...

Do you have ssh or telnet servers enabled on the machine?  If so, when
it 'freezes' can you log into it remotely and assess the situation?

> Well that's not the end of my sad history, if i try the same, not as
> user but root, the xwindows works fine; indeed i'm working as root at
> this moment.

I'm not going to lecture on the dangers of X as root--I'm sure you'll
get that from others.

>    I have the following configuration.
> Laptop: Dell Inspiron 5150
> Mem:        775072
> Mobile Intel(R) Pentium(R) 4     CPU 3.06GHz
> VGA compatible controller: nVidia Corporation NV34M [GeForce FX Go5200]
> Linux julisa 2.6.15julisa #7 PREEMPT Thu Jun 8 23:13:53 CDT 2006 i686
> GNU/Linux
> My Debian Repository (apt):
> http://ftp.us.debian.org/debian testing main contrib non-free

Just as a note--until etch is released, I'd consider adding a line:
deb http://secure-testing.debian.net/debian-secure-testing \
        etch/security-updates main contrib non-free

> So, every day or so i made the:
> apt-get update && apt-get dist-upgrade

good to stay up-to-date and to help test new packages (the two reasons I
can think to use testing/unstable)

> ----------PARTIAL LOG--------------
> _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
> _XSERVTransOpen: transport open failed for inet6/julisa:0
> _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
> X Window System Version 7.0.0
> Release Date: 21 December 2005
> X Protocol Version 11, Revision 0, Release 7.0
> Build Operating System:Linux 2.6.12-1-686 i686
> Current Operating System: Linux julisa 2.6.15julisa #7 PREEMPT Thu Jun 8
> 23:13:5
> 3 CDT 2006 i686
> Build Date: 16 March 2006
>        Before reporting problems, check http://wiki.x.org
>        to make sure that you have the latest version.
> Module Loader present
> Markers: (--) probed, (**) from config file, (==) default setting,
>        (++) from command line, (!!) notice, (II) informational,
>        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jun  8 23:45:13 2006
> (==) Using config file: "/etc/X11/xorg.conf"
> (==) ServerLayout "Default Layout"
> (**) |-->Screen "Default Screen" (0)
> (**) |   |-->Monitor "Monitor genérico"
> (**) |   |-->Device "Tarjeta de vídeo genérica"
> -------------------------------

Is that all that's in te X logs?  What does ~/.xsession-errors contain?
Have you tried moving your .xsession and .xinitrc out of the way and
trying with fresh (IE blank) files?  What about /var/log/X.org.log --
any lines in there with either a WW or an EE (grep would be helpful)?

Christopher Nelson -- chris@cavein.org
You need no longer worry about the future.  This time tomorrow you'll be dead.

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

E. F. M.  Cederik L. De León Acuña
Tel: +52 (443) 312 68 45
Cel: +52 (443) 136 83 36
Morelia Michoacan

Reply to: