[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: (Solved, I think) apt, dpkg and dependancies



Marc Shapiro wrote:

I have been trying to install OOo2 on Sarge from backports.org but OOo-base insists that it wants j2re1.4 | java-gcj-compat | java2-runtime, none of which are in Sarge, or backports.

I have the j2re1.4 and jdk1.5 from Sun installed, so I installed the package with 'dpkg --ignore-depends=j2re1.4' and it installed OK. If I look at Tools|Options|Java the app finds both versions of Java and selects jdk1.5 as its default. So far, so good.

Now, however, every time I try to run apt-get, it complains about the missing dependancy and wants me to run 'apt-get -f install' which then wants to remove OOo-base. I don't want to remove OOo-base. I want apt to know that the dependancy is filled. How do I do that?

I found java-package and ran it against the .bin files that I got from Sun to generate Debian packages for the jdk1.5 and jre1.4. This provided java2-runtime, among others. I was then able to go to Tools|Options|Java and add both packages at their new locations.

Is there anything else that I should be doing?

--
Marc Shapiro

No boom today. Boom tomorrow. There's always a boom tomorrow.
What?! Look, somebody's got to have some damn perspective around here.
Boom. Sooner or later ... boom!

- Susan Ivanova: B5 - Grail



Reply to: