[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem updating doodled

On Wednesday 31 May 2006 08:36, Florian Kulzer wrote:

> I would first try to find out why the pre-removal script cannot stop the
> daemon. Is the daemon running at all? You can check it with
> ps -ef | grep [d]oodled
> If the daemon is not running you can try the start/stop actions yourself
> (as root):
> invoke-rc.d doodled start
> invoke-rc.d doodled stop
Start works, stop fails.

> Maybe that will give you an error message which indicates what is wrong.
> If there is no error you can start the daemon again and see if that is
> enough to satisfy the pre-removal script.
> If all else fails you can try to force the removal of the package:
> dpkg -r --force-all doodled
This doesn't work - it still complains that the stop of the daemon fails.

I then simply tried commenting out the guts of the stop function 
in /etc/init.d/doodled and running the upgrade, which worked.

invoke-rc.d doodled stop still fails.  Here is the function 
from /etc/init.d/doodled:

DESC="doodle daemon"

              echo -n "Stopping $DESC: "
              start-stop-daemon --stop --quiet --pidfile /var/run/$NAME.pid \
                      --exec $DAEMON
              echo "$NAME."

Michael Lightfoot


Reply to: