[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sarge on libretto110ct

Hi Luda,

Congratulations on getting your install done. I read your post,
and it sounds like it took a lot more ingenuity than it should
have done. It sounds like the hard disk install from Windows
needs a bit of work...

I also completely sympathize with your comments about system
administration. I moved to Debian from SuSE because I didn't
want GUI system administration tools like YaST2 trying to second
guess what I wanted to do - trying to wade through all the scripts
that it was using to try to firgure out what it was doing was an
order of magnitude more complex than just doing the configuration
by hand..

In fact I am still not really comfortable with package management
tools like APT or RPM which try to dictate to me where things
should go and how they should be built. At the risk of sounding
a bit like a luddite, I was quite happy with the way my old BSD
system kept everything that was not part of the original distribution
either in /usr/local or personal directories, and new applications
were installed from a tarball with autoconf. It took a lot longer,
but as you say, the end result was I system that I knew better..

> Thanks to your help, I was able to install Sarge on my Libretto. I posted 
> how I did it on the lists, since it is a bit different from your 
> suggestions. Still, there are a few things this stubborn Libretto does not 
> want to do for me. For example, the screen is 800x480, but it insists on 
> displaying 800x600, so I lose a part of the image. How can I talk it into 
> displaying 800x480 only?

Yeah, that took a bit of digging to get to the bottom of that.

The secret incantation that beat the neomagic driver into submision
for me was:
	Option "overridevalidatemode"

Without that it seems to think it knows better than you do what
modes to use...

If you can't get it going, let me know and I'll send you a copy
of my config.

> Also, while Sarge (very nicely!) loads all the 
> necessaries for usb, it complains when I plug in the pcmcia usb card:
> usb-ohci.c: found ohci device with no irq assignment. check bios setings!
> PCI: No IRQ known for interrupt pin B of device 15:00.1. Please try using 
> pci=biosirq.
> And do it goes for all pins. Of course, no usb devices pluggged in it 
> work.

Do you see any indication that it recognises the PCMCIA card as a
USB interface?? Do you know that the card works on other Linux

I tried one about 18 months ago (I was still running SuSE at that
point) but couldn't find a driver for it.

Instead I picked up a cheap Libretto 'enhanced port replicator' on
ebay, which provides a built in USB port (amounst other things like
additional PCMCIA, separate mouse+keyboard connectors etc), and
that USB seems to be much more standard and worked out of the box.

Of course it would be a whole lot more convenient when travelling
if the PCMCIA solution worked.

> And lastly, that thing runs HOT! From your experience, is that really 
> normal? When I pull the PCMCIA cards from it, they are so hot, I worry 
> just how well they would work...

Heat can be a problem on the libretto - especially in hot weather when
docked in the EPR. I have had it spontaneosly shutdown (it hibernates)
due to overheating. Though normally only when the weather has gotten
to the point where I am feeling uncomfortable as well.

Sometimes when I am using it remotely (I like to use an X terminal
when using it at home to improve the ergonomics) I just remove the
keyboard to give it better ventilation.

Digby R. S. Tarvin                                          digbyt(at)digbyt.com

Reply to: