[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: keyboard not working anymore in Xorg



On Fri, May 26, 2006 at 12:09:20 +0200, Bart Schelstraete wrote:
> Hi,
> 
> I'm using the current Debian 'unstable', and since yesterday my X
> doesn't accept the key inputs anymore. When I press a key, nothing
> happens. So my X is unusable.
> 
> I noticed the log below, somebody who knows what I can do about this?
> 
> As you can see in the log, I'm using X.org.
> 
> --
> X Window System Version 7.0.0
> Release Date: 21 December 2005
> X Protocol Version 11, Revision 0, Release 7.0
> Build Operating System:Linux 2.6.12-1-686 i686
> Current Operating System: Linux debian 2.6.16-1-686 #2 Thu May 4
> 18:22:23 UTC 2006 i686
> Build Date: 16 March 2006
> 	Before reporting problems, check http://wiki.x.org
> 	to make sure that you have the latest version.
> Module Loader present
> Markers: (--) probed, (**) from config file, (==) default setting,
> 	(++) from command line, (!!) notice, (II) informational,
> 	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> (==) Log file: "/var/log/Xorg.0.log", Time: Fri May 26 11:55:35 2006
> (==) Using config file: "/etc/X11/xorg.conf"
> expected keysym, got XF86_Switch_VT_1: line 8 of xfree86
> expected keysym, got XF86_Switch_VT_2: line 11 of xfree86
> expected keysym, got XF86_Switch_VT_3: line 14 of xfree86
> expected keysym, got XF86_Switch_VT_4: line 17 of xfree86
> expected keysym, got XF86_Switch_VT_5: line 20 of xfree86
> expected keysym, got XF86_Switch_VT_6: line 23 of xfree86
> expected keysym, got XF86_Switch_VT_7: line 26 of xfree86
> expected keysym, got XF86_Switch_VT_8: line 29 of xfree86
> expected keysym, got XF86_Switch_VT_9: line 32 of xfree86
> expected keysym, got XF86_Switch_VT_10: line 35 of xfree86
> expected keysym, got XF86_Switch_VT_11: line 38 of xfree86
> expected keysym, got XF86_Switch_VT_12: line 41 of xfree86
> expected keysym, got XF86_Ungrab: line 45 of xfree86
> expected keysym, got XF86_ClearGrab: line 48 of xfree86
> expected keysym, got XF86_Next_VMode: line 51 of xfree86
> expected keysym, got XF86_Prev_VMode: line 54 of xfree86
> The XKEYBOARD keymap compiler (xkbcomp) reports:
> >Warning:          Multiple interpretations of "NoSymbol+AnyOfOrNone(all)"
> >                  Using last definition for duplicate fields

[ warning repeated 14 times ]

> expected keysym, got XF86_Switch_VT_1: line 52 of pc
> expected keysym, got XF86_Switch_VT_2: line 56 of pc
> expected keysym, got XF86_Switch_VT_3: line 60 of pc
> expected keysym, got XF86_Switch_VT_4: line 64 of pc
> expected keysym, got XF86_Switch_VT_5: line 68 of pc

What is your keyboard configuration in xorg.conf? Please run the
following command and post its output:

awk '/Section "InputDevice"/,/EndSection/' /etc/X11/xorg.conf

-- 
Regards,
          Florian



Reply to: