[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wireless troubles



Freddy Freeloader wrote:

Freddy Freeloader wrote:

Hi all,

I'm having problems getting wireless up and running on my laptop.

Here is the appropriate portion of /etc/network/interfaces:

# wireless
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa_conf /etc/wpa_supplicant.conf


Here is my /etc/wpa_supplicant.conf:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

eapol_version=1
ap_scan=2
fast_reauth=1

network={
       ssid="gawako"
       mode=shared
       proto=WPA
       key_mgmt=WPA-PSK
       pairwise= CCMP TKIP
       group=CCMP TKIP
       psk="mykey"
       priority=4
}
network={
       ssid=""
       key_mgmt=NONE
}


I have tried this without "mode" and "group".  I have also tried this
without CCMP.

wpa_supplicant is running.

Wayne:/var/log# ps -A | grep wpa
14072 ?        00:00:00 wpa_supplicant

ifup wlan0 brings the interface up and dhcp discovery runs as it should.
I just get lease offers.  I have tried this both with secured and
unsecured access points, and I never recieve dhcp offers.

Anyone have any idea as to what I am doing wrong?  This wireless thing
is new to me.


OK. Here is something that is really strange. I walked away from my laptop for a few minutes and when I came back I ran an "ifup wlan0". I received a message that says "interface wlan0 already configured." So, I ran an "ifconfig -a" Now, my wireless router is attached to my wired router as a separate subnet off on of the LAN ports. wlan0 picked up an IP address from the dhcp server on my wired subnet rather than the dhcp server off my wireless router. Does the dhcp server on the wireless router work? Yes. I can get IP addresses from it if I boot my laptop into Windows. How weird is that? So, I have an IP address on my wireless connection but it isn't connected to my wireless router. My wireless subnet is 192.168.2.0. My wired subnet is 192.168.1.0. My laptop has an IP address of 192.168.1.101.
I have to say, I am thoroughly confused as to why this is happening.



Well, as a fitting end to this I changed the wpa_supplicant.conf by getting rid of the mode=managed parameter, booted into Windows, received a wireless IP address, booted back into Debian and everything started working on boot. Why it wouldn't work before I added the mode parameter and then worked after I deleted in and booted into Windows I haven't a clue, but it now works fine.
Wireless seems to be a combination of smoke and mirrors....  :-D



Reply to: