[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: "Intel Corp. PRO/Wireless 2200BG" stopped working in Linux

On 5/18/06, Sergio Basurto Juarez <sbasurtoj@yahoo.com> wrote:

George Hein <zweistein@optonline.net> wrote:

Fawad Nazir wrote:
> Hi All,
> I am running, Ubuntu 5.10 and Linux v2.6.16.5.
> I just upgraded my Linux kernel and my "Intel Corp. PRO/Wireless
> 2200BG" stopped working.
I previously did some upgrade and required an upgrade of the firmware
from intel before I could get my 2200 working on my ThinkPad-T42.

This was due to going form 2.6.15 to 2.6.16 or something like that on
Debian test and sid.

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact


You must recompile the driver in order to works for a new kernel.

# make && make install

I tried to recompile the ipw2200 driver from the source code:

I got into some problems:

fawad@Ubuntu-01:/usr/src/linux/ipw2200-1.1.2$ make

ERROR: ieee80211.h not found in '/lib/modules/'.

You need to install the ieee80211 subsystem from http://ieee80211.sf.net
and point this build to the location where you installed those sources, eg.:

% make IEEE80211_INC=/usr/src/ieee80211/

will look for ieee80211.h in /usr/src/ieee80211/net/

make: *** [check_inc] Error 1

The i checked the path of my ieee80211.h and corrected the Makefile
with giving the path of : /usr/src/linux-
fawad@Ubuntu-01:/usr/src/linux/ipw2200-1.1.2$ locate ieee80211.h

After doing that i ran make again and got the following output:

fawad@Ubuntu-01:/usr/src/linux/ipw2200-1.1.2$ sudo make
mkdir -p /usr/src/linux-
cp /lib/modules/*.mod
cp: cannot stat
No such file or directory
make: [modules] Error 1 (ignored)
make -C /lib/modules/
make[1]: Entering directory `/usr/src/linux-'
 CC [M]  /usr/src/linux-
/usr/src/linux- In function
/usr/src/linux- error:
'WLAN_AUTH_LEAP' undeclared (first use in this function)
/usr/src/linux- error: (Each
undeclared identifier is reported only once
/usr/src/linux- error: for each
function it appears in.)
/usr/src/linux- In function
/usr/src/linux- error:
'WLAN_AUTH_LEAP' undeclared (first use in this function)
make[2]: *** [/usr/src/linux-] Error 1
make[1]: *** [_module_/usr/src/linux-] Error 2
make[1]: Leaving directory `/usr/src/linux-'
make: *** [modules] Error 2

I have gentoo 2005.1 on a Sony VAIO and each time I recompile my kernel or
update my kernel I shoud recompile the driver for my PRO/Wireless 2200 in
order to get it work.

I hope this help.

Sergio Basurto J.

If I have seen further it is by standing on the
shoulders of giants. (Isaac Newton)

Love cheap thrills? Enjoy PC-to-Phone calls to 30+ countries for just 2¢/min
with Yahoo! Messenger with Voice.

Fawad Nazir

Reply to: