[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Alsa breaks after kernel upgrade

On Thu, 2006-05-11 at 09:34 -1000, Javier-Elias Vasquez-Vivas wrote:
> On 5/11/06, John L Fjellstad <john-debian@fjellstad.org> wrote:
> > Chris Abajian <chris@abajian.net> writes:
> >
> > > Sound used to work fine.  Running Sarge distro kernel 2.6.8-2-386,
> > > Alsa was happy.  Life was good.  Sndstat said:
> >
> > <snip>
> > >
> > > Upgraded to new kernel,, built from source starting with
> > > old .config.  Everything looked good...

Why are you compiling your kernel? You aren't using the latest
kernel.org sources. There is no reason then.

If you MUST get a newer kernel, you will need to update the version of
udev as any kernel 2.6.12(really 2.6.11, but stay away from that one) or
later has to have a 090 or newer version of udev. Along with many other

Gone are the days of just compiling a new kernel and plopping it in.

> > Are you using udev?  If you are, did you upgrade your udev?
> I don't know what do you mean with crash.

Crash, where did he say that? No you need to update the udev for your
machine. if you use 2.6.14 again, you must have AT LEAST 090 version of

> But any time I update kernel and reboot with the new one, I need to
> run alsaconf again to set the right driver and modify the modules
> stuff (which is an easy proccess through alsaconf).  If I don't do
> this sound doesn't work. If you have tried this already, please
> disregard my comment.  If not, then it's an easy trial.  Now if this
> is the problem, I think there's no way to launch alsaconf on the
> kernel upgrade itself since a reboot is required to launch the new
> kernel, so I believe this has to be manually done, well if you
> experience this problem I do on any kernel upgrade.  This is
> independant of udev usage for me.  I had to do this in old hotplug
> times, and I have to do it in new udev times as well...

I am running sid with the 2.6.16 kernel from Debian. I ran alsaconf once
a long time ago. Back around 2.4.22 being in testing and no 2.6 at all.
change the hardware out from underneath the Installation. Since, I have
only had to fitz with modules only when I change the hardware, I think
it'd be good for you to somehow switch to Sid... and run the latest

Only issue I had was getting nVidia stuff to play nice back then. It is
a whole different ballgame now.

BTW, Hotplug the package is deprecated in etch. 
greg, greg@gregfolkert.net

The technology that is
Stronger, better, faster:  Linux

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: