[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: AMD 64 on HP laptop

Florian Kulzer wrote:

On Fri, May 05, 2006 at 13:09:55 -0700, Freddy Freeloader wrote:
I have a HP Pavilion dv8000z laptop with a 2.0 ghz AMD Turion, a gig of ram, and dual 80 gig hard drives. I have tried to install the AMD 64 version of Sarge twice on this machine. Both times it has been so slow I've given up and installed the 32 bit version of Sarge. I just did, or should say attempted, an 64 bit install today. It took 55 minutes to do a base install from a netinstall cd, 10 minutes of which it spent on just loading the kernel-image package. I can complete a default 32 bit Sarge desktop install in approximately the same amount of time. I started my install at 11:15 this morning, it is now 12:59, and the system is just now unpacking the downloads for a default desktop install. That's 1 3/4 hours and it hasn't even begun setting up packages yet. This install will probably take at least 3 hours to complete, if not more.

Anyone know why this is so slow? I would have completed the same default desktop bit install an hour ago on this machine if I had installed the 32 bit version of Sarge. Running 32 bit sarge or sid this laptop is every bit the equal of my 32 bit desktop machines of similar cpu speed even though it only has 4200 rpm hard drives and my desktops have 7200 rpm hard drives. The 64 bit version of Debian makes this thing crawl. It takes at least 8 - 10 seconds to open Firefox. The 32 bit install opens Firefox in less than 1/2 the time.

Maybe the 64 bit install has a problem with DMA; that can cost you a
factor 10 in harddrive access times. You can check this with "hdparm".


You were correct on the dma bit. Unfortunately hdparm errors out when trying to enable dma so it isn't possible to change the setting. The BIOS is of no help as there are basically no options available for changing anything in it. :( The other problem is that the system uses all but 10 megs of the gig of ram with nothing running but Gnome and the Gnome terminal. It's a double whammy. No memory available except for swap and dma disabled. I figured by the time I had the system installed I might as well see what it was like so I tried to install the ATI drivers so the cpu wouldn't need to do all the graphics work. Well, that didn't work either. Using ATI's automated driver installer resulted in a missing file error when trying to use the aticonfig tool. Trying to generate a Debian package failed too because the window that the ATI installer uses to walk you through the process wouldn't fit into an 800x600 resolution screen--the best resolution available using the vesa driver--leaving me with no way of telling the installer what choices I had made because the OK button was off screen and I couldn't resize or move the installer window enough to gain access to it. I then tried to use the .rpm package from ATI and alien to install the video drivers. That failed too. It was the last straw. I'm putting etch back on the system this morning as I write this. The netinstall has been running for 15 minutes as I write this and it's already done the base install and is more than 1/2 way through the file download.

Reply to: