[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Sarge on SATA

Thanks for the information so far.
I know it sounds strange, that I cannot change any settings in my BIOS, unfortunately that is true - if anybody is interested I can prove it with screenshots :-) I already read the very same information in various articles. I tried to unselect all unnecessary drivers, but it didn't help either. My CDROM works fine, only after loading the wrong drivers I had some issues with it, but that's pretty obvious. I guess I will give the Etch CD a shot, haven't tried this so far. Thanks for the advise.

If I don't find a solution, I will go ahead and buy an IDE drive to install Debian to; I just can't believe, that I can't get it to work with SATA and this really bugs me... :-)

Am I the only person who has problems installing Debian on SATA?


Dave Witbrodt wrote:

I'm new to the list and fairly new to Debian. I recently bought myself a new PC (HP Pavilion a1320n) with a SATA drive. I know, that there is an issue with the 2.4 kernel and I know that it is supposed to work with the 2.6 kernel. For some reason I can't get it to work, though. As soon as the installer tries to locate the HDD it fails with an error message. I also tried to change the BIOS settings, as some articles recommended, from "Normal" to "Combined" (SATA/PATA) - however my BIOS does not have any settings I could change (concerning the SATA drive). Some other linux distribution ("PC rescue CDs") were able to detect and display the SATA drive.

  I'm going to take a shot at this, though I'm no expert or guru.

I have a Dell Pavilion 8400 from last year, and it shipped with a SATA150 drive. I was also not able to install Sarge until I altered my BIOS settings from SATA/AHCI mode to UltraATA-emulation mode. It sounds like your BIOS doesn't allow that, though I'm a bit surprised if that's true. (No offense.)

  There are two possibilities that I know of:

1) I read in different places about conflicts between CD drivers and SATA drivers on the Sarge installation CDs. One link actually provided instructions about temporarily removing a module until the hard drive was partitioned, then restoring it. The Sarge installer documentation also mentions a slightly reminiscent problem:

    SATA driver can block access to CD drive in installations
    from CD.  On systems having a SATA IDE controller that also
    has the CD drive connected to it, you may see the installer
    hanging during hardware detection for the CD drive or failing
    to read the CD just afterwards. A possible reason is that the
    SATA driver (ata_piix and maybe others) is blocking access to
    the CD drive.

    You can try to work around this by booting the installer in
    expert mode and, in the "Detect and mount CD-ROM" step,
    selecting only the drivers needed for CD support. These are
    (ide-)generic, ide-cd and isofs.

    The drivers needed to access the disk will still be loaded,
    but at a later stage. By loading the CD drivers before the
    SATA driver in this way, you may be able to complete the
    installation. Note that CD-ROM access may still be an issue
    after rebooting into the installed system.


On the other hand, it's very possible that the kernel on the Sarge installer CD simply doesn't have support for your hardware. I actually was unable to install Sarge onto my older Pentium 3 machine because I was using a PCI controller that would allow me to use larger hard drives that my motherboard's controller could handle. The crazy thing was that, even though the kernel on the CD couldn't recognize the controller, when I installed Debian to a drive on the motherboard controller the kernel _did_ recognize the PCI controller. I had to move everything from the old hard drive to the new one.

2) If the Sarge CD can't do it, then you can try a recent Etch CD, which has a newer kernel and is far more likely to recognize your hardware. They've even got the Etch installers to work now! ;) (For a long time, if you burned an Etch netinstall CD and tried to use it, it just wouldn't work -- not without massive user intervention, anyway.)

Dave W.

Reply to: