[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ndiswrapper, wireless driver and 64 bit kernel

Freddy Freeloader wrote:

Hi All

I'm running a combination of etch and sid on an HP Pavilion dv8000z that runs the AMD Turion. I'm running 32 bit Debian with the 64 bit kernel that is released with sarge, etch, and sid.

I've been trying to get my wireless going and having problems getting it up and running. The laptop has the Broadcom wireless card and lspci reports it as a bcm4318. I ran ndiswrapper and it ran successfully. ndiswrapper -l lists the driver and says the driver and hardware are present. However when I went to run modprobe ndiswrapper it reported a fatal error: Module not found.

I located ndiswrapper.ko (It was with the 2.6.8-2 module that etch and sid both install as the ndiswrapper module), and added the directory to the PATH. Now when I run modprobe I'm getting the "invalid module format" error.

I'm having trouble figuring out exactly what is causing the problem. Is it because the ndiswrapper is from a different kernel, or does this error have anything to do with possible differences in compilers? How do I figure out which is the problem? I am not running a custom kernel other than it's a 64 bit kernel, rather than a 32 bit kernel.

As a further update:

I tried using module-assistant to install ndiswrapper from source today and it failed. It says it can't find any source for the kernel. uname -a says the kernel is 2.6.15-1-486. That seems like a pretty strange naming convention for a 64 bit kernel but that's what it reports.

Reply to: