[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

How do I completely reconfigure my network connection?


If you don't want to read the whole story, I'm curious about how I can
re-set all of the settings for the network (for instance if everythign
was broken that you debug going through the list from the "HOWTO -
Basic Network Troubleshooting / Understanding"):
  - Is the interface configured correctly ? (lspci, lsmod, dmesg,
ifconfig /etc/network/interfaces)
  - Is/Are DNS / hostnames configured correctly ? (Bind, /etc/hosts,
  - Are the ARP tables correct ? ( arp -a )
  - Can you ping the localhost ? (ping localhost / *try both*)
  - Can you ping other local hosts (hosts on the local network) by IP
Address? How about hostname? (ping)
  - Can you ping hosts on another network (ala internet) ? (ping)
  - Do applications like ssh, firefox, sftp, etc, work ? (chosen application)

If there's no good way to do that or if it's a huge task, then here
are the symptoms for my problem(s):

I have an HP Pavilion with what seems to be all nVidia cards inside
it, which has been giving me trouble since last week when I decided to
install Debian.  I struggled for hours with the net install and
finally remembered that I had a spare network card in my garage. 
After plugging that in, the network install worked fine, but eth0 has
been inactive.  Last night I decided to get the nVidia nForce card
(nVidia Corporation nForce Ethernet Controller (rev c2)) up and
running.  I don't even remember what I did, but I stumbled across
enough information advising me to upgrade the kernel to 2.6 (from
2.4.27-2-386) that I gave up on whatever I was trying.  Now my short
term goal is to get the 3com ethernet card working again (3Com
Corporation 3c905B 100BaseTX [Cyclone] (rev 30)).  Then I can apt-get
to upgrade the kernel.  The merits of Debian quickly disappear when
I'm stupid enough to hose my network connection, disabling apt-get.

I would be content to run the network configuration that I ran when I
first installed Debian.  I searched for a while on the internet to
figure out how to do this, but then gave up.  Otherwise, it would be
fine to fix the actual problem if that can be done easily.  I'm nearly
ready to format and re-install, but I have actually done some useful
things on the computer, including backing up my Mac (which is
concurrently on the fritz).

I have run "dpkg-reconfigure etherconf" multiple times, both setting
up the 3com card with DHCP and statically.  Currently, under DHCP my
system is capable of getting an IP address from my router -- or at
least it leads me to believe it is:
   Listening on LPF/eth1/00:01:02:36:6b:ef
   Sending on LPF/eth1/00:01:02:36:6b:ef
   Sending on Socket/fallback/fallback-net
   DHCPREQUEST on eth1 to 255.255.2552.55 prot 67
   DHCPACK from
   bound to -- renewal in 43200 seconds.
Note that is the host -- I changed it from .1 after
reading something that seems not to have applied.  I am able to ping
all of localhost, (which is localhost), and
(which is also the same machine).  I am able to broadcast ping, but not (the same is true with .255 instead of
.0).  When I try to broadcast ping I get:
   ping: sendmsg: Operation not permitted
   ping: sendmsg: Operation not permitted
Not only can I not broadcast ping, but I cannot ping the host by
number -- with the exception of testing localhost, I have been
attempting to ping using ip addresses and not names (the same is true
with the setup through dpkg-reconfigure etherconf).  Here's what I get
when I try to ping the host:
   /home/rls# ping
   PING ( 56(84) bytes of data
   From icmp_seq=1 Destination Host Unreachable
   From icmp_seq=1 Destination Host Unreachable
   From icmp_seq=1 Destination Host Unreachable
   From icmp_seq=1 Destination Host Unreachable
   From icmp_seq=1 Destination Host Unreachable
   From icmp_seq=1 Destination Host Unreachable
   ping: sendmsg: Operation not permitted
   From icmp_seq=1 Destination Host Unreachable
   ping: sendmsg: Operation not permitted

I read somewhere that this may be caused by iptables or other
restrictions imposed on the network, but I did not intentionally set
anything since it was working yesterday.  Again, I'd be content to
blow away much of the settings.

With static configuration, after bringing the card up I get the
message "SIOCADDRT: Network is unreachable" and when I try to ping the
host I get "connect: Network is unreachable" just once this time.

I have this computer with a floppy drive or if I need to download
serious packages, my fiancee has a dvd/cd burner on her laptop -- in
fact maybe I should just download the packages.

Your help is much appreciated!

Reply to: