[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

bootsplash in sid

I tried to install bootsplash in sid.
I had two problems.
First is regarding sysv-rc-bootsplash. It doesn't patch rc and rcs
scripts properly. Any how I tried to bypass it by removing it.
second  initrd.img gives kernel panic.
I saw post in bootsplash discussion as below.
It's because you are using a cpio'd+gzip'd initrd, instead of the
ext2+gzip'd initrd.

To get it to work follow these instructions.

~$ splash -s -f /path/to/bootsplash.cfg > bootsplash

For some reason, I had to extract the existing cpio image and recreate it,
otherwise it would fail.  I assume it has something to do with the way
mkinitramfs is creating it.

~$ mkdir initrd.d && cd initrd.d && gunzip < /path/to/initrd.img | cpio -i
~$ find . | cpio -o -H newc > ../initrd && cd ../ && rmdir initrd.d
~$ echo bootsplash | cpio -o -H newc >> initrd
~$ gzip -9 < initrd > initrd.img $$ rm -f initrd

A reply was given as below
> ~$ mkdir initrd.d && cd initrd.d && gunzip < /path/to/initrd.img | cpio -i
It does not work.
gunzip refuses to uncompress Linux Compressed ROM File System.

Instead, I select cramfs in linux kernel, and now, it works fine

As their email ids are not given I am posting here. How to use cramfs
instead of gunzip. If someone can explain those steps above, it will
help me understand.
Has anyone sucessfully installed bootsplash in 2.6.15? Kindly tell me
the steps to follow to avoid above problems.
linux user No.205042

Reply to: