[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

udev is ruining my life


I want to provoke some comment.  Maybe we can salvage this situation. 

(Mitchell dons his flame retardent  clothes and jumps into swimming pool).

I am getting creamed by udev. 

I just installed sarge on a ibook. I upgraded to sid and upgraded to latest 
debian kernel 2.6.15. I then tried to get alsa working. I was killed by "no 
device" for sound. 

apt-get remove --purge udev

Then I could get some sound.

I have about 15 sarge servers, about 10 terabytes of data stored on sarge 

I set up new Sarge systems all the time, system on a ide single drive and then  
create storage raids on separate drives. 
If I try on a fresh install of sarge, then when I try to run
mdadm -Cv /dev/md0 -l1 -n2 /dev/sda1 /dev/sda2 
mdadm -Cv /dev/md0 -l5 -n4 /dev/sda1 /dev/sda2 /dev/sdc1 /dev/sdd1

Guess what I get???

"no device /dev/md0"

So guess what I do? 

apt-get remove --purge udev

Then I reboot and now I have /dev/md0.

This is crazy. Why cant udev just leave us alone in basic situations. 

We all need sound. We all can use software raid. Why cant udev meet our needs 
out of the box????? Why are we being tortured?????

I have gamely tried to  go along with   udev. I have dutifully read the udev 
documentation. I have read the original articles proposing it. I have read 
flamewars about it. I have even tried vainly to understand  and create rules.

But frankly, I feel that there devices I am talking about are so basic and the 
whole idea of devices should not be so complicated.

Now we cant upgrade debian provided kernels beyond 2.6.11 without udev? Why is 
this a prerequisite?? I can install my own kernel without it.

Devices are a basic thing, usually dealt with at initial system put together, 
or perhaps when I plug in a usb device, that it is a special annoying 
headache to spend days to figure these special rules things out. 



Reply to: