[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gpg key error in unstable


L.V.Gandhi (<lvgandhi@gmail.com>) wrote:

> I have sarge system. I use other repositories like
> http://ftp.nerim.net, http://ftp.debian-unofficial.org,
> http://www.backports.org. I upgraded apt to 0.6.43. it needs gpg keys
> for all. I went to nerim and saw merillat key. I did
> lvgdell600m:~# gpg --armor --export 1F41B907 | apt-key add -
> gpg: directory `/root/.gnupg' created
> [...]
> gpg: WARNING: nothing exported
> gpg: no valid OpenPGP data found.
> even then I got warning during apt-get update. then I tried
> lvgdell600m:~# gpg --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys
> 1F41B907 gpg: requesting key 1F41B907 from hkp server
> wwwkeys.eu.pgp.net gpg: /root/.gnupg/trustdb.gpg: trustdb created
> gpg: key 1F41B907: public key "Christian Marillat
> <marillat@debian.org>" imported
> gpg: no ultimately trusted keys found
> gpg: Total number processed: 1
> gpg:               imported: 1
> even now I got warning during apt-get update
> what to do?

The first time you tried to export the key from gpg to apt, but you
didn't have the key in your gpg keyring. The second time, you imported
the key to gpg, but didn't feed it to apt.

best regards
        Andreas Janssen

Andreas Janssen <andreas.janssen@bigfoot.com>
PGP-Key-ID: 0xDC801674 ICQ #17079270
Registered Linux User #267976

Reply to: