[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sarge sec update: sudo_1.6.8p7-1.3_i386.deb probs

On Fri, Jan 20, 2006 at 08:02:33AM -0600, Hugo Vanwoerkom wrote:
> Hi,
> I just did a security upgrade with Sarge and got installed 
> sudo_1.6.8p7-1.3_i386.deb. But when I use sudo to get to synaptic I get:
> (synaptic:25937): Gtk-WARNING **: cannot open display:
> When I then reinstalled the previous version:
> sudo_1.6.8p7-1.2_i386.deb
> The problem goes away.

This paragraph was in the security announcement posted to
debian-security-announce list:

------------ begin excerpt -----------
This update alters the former behaviour of sudo and limits the number
of supported environment variables to LC_*, LANG, LANGUAGE and TERM.
Additional variables are only passed through when set as env_check in
/etc/sudoers, which might be required for some scripts to continue to
------------- end excerpt ------------

Maybe you need to do something with the DISPLAY	variable in /etc/sudoers. 
This is just a guess, however.


Reply to: