[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Power down

Andrei Popescu wrote:

On Mon, 16 Jan 2006 14:02:58 +0000
"Elmer E. Dow" <elmeredow@earthlink.net> wrote:

Vincent Smeets wrote:


I have an old (1999) computer too. dmesg showed that the kernel does find my ACPI but doesn't use it because my bios is too old. It says something like "... bios too old (1999 < 2001)". I now use the kernel parameter "acpi=force" and now the kernel is using my ACPI. Poweroff does now realy switch the power off!

I've read that acpi=force works with 2.4 kernels but not 2.6 like mine. What kernel are you using?

If you look at your dmesg it suggests just that, enabling it. It can't hurt to try

Also, power management is enabled in the bios. Is that correct or is it fighting apm?


To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

acpi=force works! I first tried removing apmd, deleting apm in /etc/modules and adding acpi there. I also installed acpid and so on, but the machine complained of fatal errors, etc. So I uninstalled acpid, deleted acpi in /etc/modules and left just acpi=force in menu.lst -- and it worked.

So now I'm wondering how this works without the acpi module or having acpi compiled into the kernel. Does forcing acpi just makes it use the power management in the bios?

Thanks, gentlemen, for your kind assistance.


Reply to: