[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

fsck Fails On Reboot After Partially Completed Testing Upgrade

I get these boot messages on a cold start or reboot
after doing an
# aptitude upgrade -t testing that is still not
completely finished.

Checking root file system
fsck 1.39-WIP(current date)
/dev/hda1: Superblock last write time in future
without -a or -p options

fsck failed. Please repair MANUALLY and reboot. Please
note that root file system is currently mounted
To remount it read-write:
#umount -n -o remount,rw /
Control D will exit from this shell and REBOOT the

Give root password for maintenance
(or type Control D to continue)

I've followed these instructions several times and
still get the error on bootup.  When I run fsck from
root after mounting /,rw, I get a warning about
running fsck on a mounted fs and select "no" to
continue.  It asks me if I want to fix each partition
and I say yes and reboot as instructed and can then
boot up the system but the next time I start the
computer it all starts over again.
I have an ext3 fs and after running fsck on a mounted
fs before and having to do a complete reinstall and
having several of the users advise me to never do
this, I didn't.  So, how can I fix this problem?  Any
suggestions appreciated.  Please copy my email address
as I'm not suscribed.

Reply to: