[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Java plugin fails after installing java3d

Friendly Debian users,

I installed Sun's Java SDK and then the java3d SDK.  The Firefox
plugin worked for a time, then stopped working.  All of my debugging
tells me that it should work now, but it doesn't.  I'm running Sarge.

I installed the Sun's Java SDK using make-jpkg; everything, including
the Firefox plugin, worked fine.  Then I downloaded
java3d-sdk-1.3.1-linux-i386.bin and unpacked it in
/usr/lib/j2sdk1.5-sun/.  The plugin for Firefox worked fine and
displayed the 3d applets correctly.

The Firefox Java plugin stopped working.  I did add and remove many
packages, including moving from Gnome to fluxbox, but I did it all
through aptitude.  Appletviewer worked fine.

I purged mozilla-firefox and sun-j2sdk1.5 and then removed the entire
directory /usr/lib/j2sdk1.5-sun/ (because there were still things there
from the Java 3d SDK).  I removed the broken symbolic links
/etc/alternatives/mozilla-javaplugin.so and firefox-javaplugin.so.

	Fresh install:
I installed mozilla-firefox and my .deb of Sun's SDK.  This made a symbolic
link, /usr/lib/mozilla-firefox/plugins/libjavaplugin.so, to 
/etc/alternatives/firefox-javaplugin.so, which links to

When I enter ``about:plugins'' in the Firefox address bar, it shows that
the Java applet plugins are enabled.  When I start firefox from the
commandline and open a page that has an applet, the terminal spits out these

	Could not start JavaVM!

	VM did not start up properly
	Could not start JavaVM!

	VM did not start up properly

I did NOT unpack the java3d-sdk again.  All other parts of the Java SDK
work fine, including the appletviewer.

  My ideas about what is wrong:
The java3d-sdk that I unpacked broke something in the filesystem that
the Debian package management system has not fixed in its purges
and installs of the packages.

I made a mistake when removing the sun-j2sdk1.5 package and installed
some packages that interfere with the plugin.  I remember some
strange-looking java-related packages selected in aptitude at one point.
I have scanned my packages and I don't see anything unusual installed,

I appreciate any tips on how to debug this better.

Thank you,
Steven Wheelwright
It's never not now.
GPG Fingerprint: 809E 9E32 907D 7619 2BED  8764 108D F31C 8927 1E3F

Reply to: