[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debugging severe performance problems

Hi all!

One of my systems has a really severe performance problem. It has an AMD 
Athlon XP 1700+ CPU. It has 768 MB RAM, and only very rarely swaps 
anything. It has a 3Dfx Voodoo Banshee (rev 03) PCI card with 16 MB 
on-card RAM. The performance problems has been there since the summer. 
For some time, it ran woody with KDE 3.1 on top, then I had it tracking 
sarge in April. It performed well at that point. 

I've tried many different things, but it all boils down to that I think 
the hardware is OK, but that I really have no clue where to start.

It is my father's system, so I'm not bothered with it too often, but the 
performance is insanely bad. When it does updatedb, the system pretty 
much freezes for the time it takes to scan the disk. Firefox takes more 
than a minute to start, and a regular apt-get upgrade with trivial 
security fixes makes the load go to above 5. My own system is similar 
to this system, but has a somewhat slower CPU, and performs well. It is 
definitely not because it doesn't have the hardware.

Not to get hung up in this, but I think I first saw the performance 
problems as xfree86 4.3.0.dfsg.1-13 went into sarge. I have therefore 
been working under the hypothesis that it is connected to some X 
problems, and it seems like it just takes a long time to draw anything. 
It is hard to tell, of course, if that's a symptom or a cause. So, I 
tried replacing the 3Dfx PCI card with my own well-performing Matrox 
G450 AGP card, but that had no appreciable effect. Reducing the 
resolution to 800x600 did however help a bit. Now, I think X might not 
have anything to do with it. I have also tried a full memtest86 scan, 
but no problems were spotted by it.

I've been looking through all the logs I can think of, but seen nothing 
that meets the eye. 

One thing that has been haunting me is this error message:
ldconfig: Cannot mmap file /lib/libslang.so.1-UFT8.
I suppose that came in with a typo (UFT8 vs. UTF8), since I forgot to 
change my sources.list to stable shortly after woody was released back 
in the day. However, I've lived with this since then, and it had never 
any performance input before. It's quite funny that it remains though, 
I've upgraded the whole system since then... 

So, well, I have a system here that borders on unusable and no idea how 
to fix it. Where would you start if you had a *really* slow system?


Kjetil Kjernsmo
Programmer / Astrophysicist / Ski-orienteer / Orienteer / Mountaineer
Homepage: http://www.kjetil.kjernsmo.net/     OpenPGP KeyID: 6A6A0BBC

Reply to: