[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X11/XFree86 Problem

[ Sarge; kernel-2.6.8-2-686;
  xfree86-common-4.3.0.dfsg.1-14sarge1; kde-5:44; xscreensaver-4.21-3 ]

A new problem has arisen over the last few weeks ...

Getting up in the morning (or after a long time away from my home
machine), I see an 'xscreensaver' image "frozen" on my monitor.  The
entire local system is locked up.  The usual "C-M-F1" (console login)
and "C-M-<backspace>" (restart the X server) escapes do nothing.

Logging in from another machine shows 'xfree86' taking 98% of the CPU.  

The only way to regain access via the local keyboard and mouse is to
use a "kill -9" on the 'xfree86' process.  After a few seconds, 'kde'
comes back with the normal login screen.  (Note, however, that "C-M-F1"
still doesn't work).


  o  Anybody else having this problem?

  o  What might be the cause?

  o  Anything I can do to help determine the cause?

One thing I tried was disabling the screen saver "module" that
appeared to be running when it "hung".  That didn't help.  I've also
rebooted the entire system ... strange!

Thanks for your ideas!
Prof Kenneth H Jacker       khj@cs.appstate.edu
Computer Science Dept       www.cs.appstate.edu/~khj
Appalachian State Univ
Boone, NC  28608  USA        

Reply to: