[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

linux-image/ramdisk/boot problem


After a linux-kernel-2.6.14-2-686 upgrade a couple of weeks ago
something went wrong with yaird, and it failed to generate a ramdisk.
Thougtless as I was, I forgot to fix the problem before I rebooted, and
my computer was then unbootable.
After that, every attempt I have made to install the linux-2.6.16-2-686 package, trying with both yaird and mkinitramfs, have resulted in the system not being able to boot. The only solution I came up with was to compile a non ramdisk kernel myself, and boot with that. That worked great, but I want to use the default debian kernel. When I try to install it, using yaird to generate the ramdisk, I get the following error messages upon bootup:

ide: Assuming 33MHz system bus speed for PIO modes; override with 	
/bin/cat: /sys/block/hda/dev: No such file or directory
Waiting 1 seconds for /sys/block/hda/dev to show up
/bin/cat: /sys/block/hda/dev: No such file or directory
Waiting 2 seconds for /sys/block/hda/dev to show up
Device /sys/block/hda/dev seems to be down.
Debugging opportunity, type ^D to continue
/bin/dash: can't access tty; job control turned off

And this leaves me in a shell where I can't even type 'ls', and without access to my hard drive, of course.

I have tried with and without forcing yaird to include the piix and/or
ide_generic drivers on the ramdisk.

Any suggestions?

Best regards,

Reply to: