[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dselect: unable to open/create access method lockfile


I describe a partial solution and the next problem below.

David Kirchner wrote:
On 12/16/05, Brian C <brianwc@berkeley.edu> wrote:
dselect: unable to open/create access method lockfile

but I still get the same error. Can anyone explain how to allow dselect
to create the lockfile it wants to?

I'm not sure where it would put the lockfile, but you may be able to
find out using 'strace'. strace will show you the system calls the
process is attempting, including what files it's trying to read.
'strace -o foo dselect' and then 'grep access foo' or 'grep open foo'
may give you the answer.

trying to apt-get something gave me a more useful error and I knew I needed the following files and directories:

mkdir -p /var/lib/dpkg
touch /var/lib/dpkg/status
mkdir -p /var/lib/dpkg/updates

This allows dselect to run. However, having lost my 'status' file is now a bigger problem because it created a new status file that believes I have NOTHING installed and so it wants to re-install every required Debian package. I'd rather not find out what happens if I let it do that.

How can I create a status file that accurately reflects the packages already installed on my system?


Reply to: