[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get install tries to REMOVE my kernel



astrid jurgensen wrote:
I recently tried to download and install software using apt-get install. The process was aborted because apt-get install tried to remove the kernel. See details below:

apt-get install –no-remove xcdroast

13 upgraded, 13 newly installed, 2 to remove and 500 not upgraded.
E: Packages need to be removed but Remove is disabled

As seen in the above, 2 files are to be REMOVED: initrd-tools and kernel-image-2.4.18-1-386
The second one of these is the kernel I am currently using, and should therefore not be removed, and I guess that initrd-tools should also not be removed.
What is the cause of this problem?
(Note: It is not due to my kernel being a bit old. Others have posted questions about this problem already, and they were using more modern kernels. Unfortunately no solutions were posted.)

You have 500 packages not upgraded. It seems you are mixing different releases. You probably attempt to install xcdroast form a 'newer' version than the rest of your 500+ packages.

Suggestion: bring your system in sync; possibly by upgrading to sarge, as described in http://www.de.debian.org/releases/stable/i386/release-notes/ch-upgrading.en.html

If you are mixing different releases on purpose, you have probably encountered a situation where this doesn't work due to dependency problems.

Hope that helps,

Johannes



Reply to: