[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get install tries to REMOVE my kernel

I think you'll get a new kernel in return

2005/12/12, astrid jurgensen <ajurgensen@mail.src.wisc.edu>:

I recently tried to download and install software using apt-get install. The process was aborted because apt-get install tried to remove the kernel. See details below:

apt-get install –no-remove xcdroast

Reading Package Lists...
Building Dependency Tree...
The following extra packages will be installed:
  cdda2wav cdrecord e2fslibs e2fsprogs initscripts libatk1.0-0 libblkid1 libc6
  libc6-dev libfontconfig1 libglib2.0-0 libpango1.0-0 libpango1.0-common
  libselinux1 libsepol1 libss2 libuuid1 libxrender-dev libxrender1 locales
  lsb-base mkisofs render-dev sysv-rc sysvinit
Suggested packages:
  vorbis-tools cdrtools-doc gpart parted e2fsck-static ttf-kochi-gothic
  ttf-kochi-mincho ttf-thryomanes ttf-baekmuk ttf-arphic-gbsn00lp
  ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp sysv-rc-conf
Recommended packages:
  libatk1.0-data libglib2.0-data x-ttcidfont-conf
The following packages will be REMOVED:
  initrd-tools kernel-image-2.4.18-1-386
The following NEW packages will be installed:
  cdda2wav cdrecord e2fslibs initscripts libblkid1 libselinux1 libsepol1 libss2
  libuuid1 lsb-base mkisofs sysv-rc xcdroast
The following packages will be upgraded:
  e2fsprogs libatk1.0-0 libc6 libc6-dev libfontconfig1 libglib2.0-0
  libpango1.0-0 libpango1.0-common libxrender-dev libxrender1 locales
  render-dev sysvinit
13 upgraded, 13 newly installed, 2 to remove and 500 not upgraded.
E: Packages need to be removed but Remove is disabled

As seen in the above, 2 files are to be REMOVED: initrd-tools and kernel-image-2.4.18-1-386
The second one of these is the kernel I am currently using, and should therefore not be removed, and I guess that initrd-tools should also not be removed.

What is the cause of this problem?
(Note: It is not due to my kernel being a bit old. Others have posted questions about this problem already, and they were using more modern kernels. Unfortunately no solutions were posted.)


Sent via the WebMail system at mail.src.wisc.edu

Reply to: