[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: followup about LVM problems.



Kelly Harding wrote:
> Thanks to a few users help from various sources I've managed to fix the
> problem with LVM2 I was
> having.
> 
> It was due to 2.6 series kernel not being used that caused the problems.
> Downgrading to the version currently
> in testing rather than the version in unstable seems to have solved the
> problems with LVM2.
> 
> however I now cannot mount the partition as XFS doesn't like it.
> 
> I get the following error if I try to mount the Volume:
> 
> mount: wrong fs type, bad option, bad superblock on
> /dev/3diskvolume/3diskvolume,
> missing codepage or other error
> (could this be the IDE device where you in fact use
> ide-scsi so that sr0 or sda or so is needed?)
> In some cases useful info is found in syslog - try
> dmesg | tail or so
> 
> If i try using xfs_check on the partition/volume i get:
> 
> xfs_check: /dev/3diskvolume/3diskvolume is invalid (cannot read first
> 512 bytes)
> 
> Does this mean the parition is useless and needs to be recreated? or is
> it possible to repair and regain
> access to the data?
> 
> Any help much appreciated.
> 
> Thanks,
> 
> Kelly

If you remember the approximate sizes/locations of the partitions, you
can use parted to locate them.  It is a bit iffy, but it has worked for
me in the past.

-Roberto

-- 
Roberto C. Sanchez
http://familiasanchez.net/~roberto

Attachment: signature.asc
Description: OpenPGP digital signature


Reply to: